[BUG]AM 4.02 CTD when playing large wav files

Discuss suspected bugs with other users and Sim Innovations Staff

Moderators: Ralph, russ

Message
Author
JackZ
Posts: 2038
Joined: Mon Feb 22, 2016 1:02 pm

[BUG]AM 4.02 CTD when playing large wav files

#1 Post by JackZ » Fri Sep 10, 2021 8:53 am

Hi

The title says all
AM crashes to the desktop when loading and trying to play a large (14Mb) wav file recorded with AUdacity in 16bits PCM.
Tried with a smaller file (8.5Mb) in 24 bits PCM, with the same result

Jacques
Last edited by JackZ on Fri Sep 10, 2021 9:06 am, edited 2 times in total.
My YouTube Chanel on the A320 (Real SOPs by an Airline Pilot IRL):
https://www.youtube.com/playlist?list=P ... 0Q6SBASRqJ

User avatar
Ralph
Posts: 5500
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: AM 4.1 CTD when playing large wav files

#2 Post by Ralph » Fri Sep 10, 2021 8:55 am

I think you can do MP3 as well, might be an alternative.

JackZ
Posts: 2038
Joined: Mon Feb 22, 2016 1:02 pm

Re: AM 4.1 CTD when playing large wav files

#3 Post by JackZ » Fri Sep 10, 2021 8:57 am

Ralph wrote:
Fri Sep 10, 2021 8:55 am
I think you can do MP3 as well, might be an alternative.
That would be cool! Thought that only wav format was supported, according to the Wiki
Gonna try it right away thanks!
I think there noneless should be a kind of warning message like "audio file is too big" instead of AM crashing :D
My YouTube Chanel on the A320 (Real SOPs by an Airline Pilot IRL):
https://www.youtube.com/playlist?list=P ... 0Q6SBASRqJ

JackZ
Posts: 2038
Joined: Mon Feb 22, 2016 1:02 pm

Re: [BUG]AM 4.1 CTD when playing large wav files

#4 Post by JackZ » Fri Sep 10, 2021 9:04 am

Nope, an 1.5Mb mp3 file is not played at all, but at least AM does not crash ;)
My YouTube Chanel on the A320 (Real SOPs by an Airline Pilot IRL):
https://www.youtube.com/playlist?list=P ... 0Q6SBASRqJ

User avatar
Sling
Posts: 4693
Joined: Mon Sep 11, 2017 2:37 pm
Contact:

Re: [BUG]AM 4.02 CTD when playing large wav files

#5 Post by Sling » Fri Sep 10, 2021 9:35 am

Are you using sound_loop() because the release version has CTD when using loop rather than play. Perhaps it’s related. I thought Corjan fixed it though.

User avatar
Corjan
Posts: 2495
Joined: Thu Nov 19, 2015 9:04 am

Re: [BUG]AM 4.02 CTD when playing large wav files

#6 Post by Corjan » Fri Sep 10, 2021 10:36 am

Hi,


MP3 was introduced in AM 4.1. So the BETA should work.


Corjan

User avatar
Ralph
Posts: 5500
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: [BUG]AM 4.02 CTD when playing large wav files

#7 Post by Ralph » Fri Sep 10, 2021 10:58 am

I thought the subject said 4.1 before, or am I losing my mind? :)

JackZ
Posts: 2038
Joined: Mon Feb 22, 2016 1:02 pm

Re: [BUG]AM 4.02 CTD when playing large wav files

#8 Post by JackZ » Fri Sep 10, 2021 12:10 pm

@Ralph My bad. I was using the stock 4.02 not the beta, hence my correction in the subject.
I will try with the beta
@Sling both sound_play() and sound_loop() crashed AM
My YouTube Chanel on the A320 (Real SOPs by an Airline Pilot IRL):
https://www.youtube.com/playlist?list=P ... 0Q6SBASRqJ

JackZ
Posts: 2038
Joined: Mon Feb 22, 2016 1:02 pm

Re: [BUG]AM 4.02 CTD when playing large wav files

#9 Post by JackZ » Fri Sep 10, 2021 10:50 pm

Oh I think got it.
The first wav file was created in stereo via Audacity. Guess that the stereo format was what caused the CTD, but not only.
When I recreated a mono file of 7.4Mo, the file got played.
A 15 mb mono file got played as well with sound_play(), but sound_loop() still crashed AM
My YouTube Chanel on the A320 (Real SOPs by an Airline Pilot IRL):
https://www.youtube.com/playlist?list=P ... 0Q6SBASRqJ

User avatar
Ralph
Posts: 5500
Joined: Tue Oct 27, 2015 7:02 pm
Location: De Steeg
Contact:

Re: [BUG]AM 4.02 CTD when playing large wav files

#10 Post by Ralph » Thu Sep 16, 2021 3:44 pm

So to be clear, no issues with the beta?

Post Reply

Who is online

Users browsing this forum: Keith Baxter and 15 guests